Log In  

Whenever I leave full screen, the PICO-8 window appears as just the programs drag bar, then crashes

P#29178 2016-09-23 15:56 ( Edited 2016-10-05 20:24)

Ka-pow ... What OS are you using and version ?

P#29181 2016-09-23 16:09 ( Edited 2016-09-23 20:09)

The issue seems to have fixed itself, I can no longer reproduce it. But here's the info anyway Microsoft Windows 10, Version 1607, Build 14393.187

P#29186 2016-09-23 17:32 ( Edited 2016-09-23 21:32)

I think one other person complained about PICO in Windows 10.

Hope it doesn't occur again. If it does, let me know and I'll tell you a 'soft' version to get around it.

P#29191 2016-09-23 19:05 ( Edited 2016-09-23 23:05)

I have the same problem with Windows 7. On my other (9 years old) PC with Win10 installed works perfecly well.

P#29419 2016-09-26 03:54 ( Edited 2016-09-26 07:54)

I'm thinking now ZEP needs to modify the full-screen so all it does is maintain its current size but put a black background behind the full-size of the screen.

By doing so, you don't have problems with hardware snap and you can still see your normal icons in the taskbar below.

I'm thinking it's the hardware snap that is causing the problem.

P#29427 2016-09-26 09:52 ( Edited 2016-09-26 13:53)

Hi. I am currently running PICO-8 in Win10 with the anniversary update. It runs fine in full screen, but as soon as I try to switch to windowed mode, the application crashes as well.

P#29708 2016-09-30 00:34 ( Edited 2016-09-30 04:34)

as stated by gamax in another thread, sdl2.dll is outdated.
not saying those problems stem from there, but it might be worth an update:
https://www.libsdl.org/release/SDL2-2.0.4-win32-x86.zip
the SDL2 team is obsessive about being backward-compatible, so that shouldn't bring more trouble. of course, your mileage may still vary.

alternatively there are three options for fullscreen in config.txt:
fullscreen_method 2 // 0 maximized window (linux) 1 borderless desktop-sized window 2 fullscreen

P#29726 2016-09-30 07:21 ( Edited 2016-09-30 11:43)

Hey :)

I get this one when trying to leave fullscreen:

System Info:

                          ./+o+-       [email protected]
                  yyyyy- -yyyyyy+      OS: Ubuntu 16.04 xenial
               ://+//////-yyyyyyo      Kernel: x86_64 Linux 4.4.0-38-generic
           .++ .:/++++++/-.+sss/`      Uptime: 5h 20m
         .:++o:  /++++++++/:--:/-      Packages: 1633
        o:+o+:++.`..```.-/oo+++++/     Shell: bash 4.3.46
       .:+o:+o/.          `+sssoo+/    Resolution: 3360x1050
  .++/+:+oo+o:`             /sssooo.   DE: LXDE
 /+++//+:`oo+o               /::--:.   WM: OpenBox
 \+/+o+++`o++o               ++////.   CPU: Intel Core i5-2400 CPU @ 3.4GHz
  .++.o+++oo+:`             /dddhhh.   GPU: GeForce GTX 960
       .+.o+oo:.          `oddhhhh+    RAM: 2171MiB / 7964MiB
        \+.++o+o``-````.:ohdhhhhh+    
         `:o+++ `ohhhhhhhhyo++os:     
           .o:`.syhhhhhhh/.oo++o`     
               /osyyyyyyo++ooo+++/    
                   ````` +oo+++o\:    
                          `oo++.  

(Yeah yeah, such a beast using LXDE... i like my UI lean and mean. ;) )

P#29793 2016-10-01 10:24 ( Edited 2016-10-01 14:24)

The same problem. Windows 7 64bit. Here is crash dump:

*******************************************************************************
*                                                                             *
*                        Exception Analysis                                   *
*                                                                             *
*******************************************************************************

*** ERROR: Symbol file could not be found.  Defaulted to export symbols for SDL2.dll - 
GetPageUrlData failed, server returned HTTP status 404
URL requested: http://watson.microsoft.com/StageOne/pico8_exe/0_0_0_0/______21/pico8_exe/0_0_0_0/______21/c0000094/00094653.htm?Retriage=1

FAULTING_IP: 
pico8+94653
00494653 f77c2428        idiv    eax,dword ptr [esp+28h]

EXCEPTION_RECORD:  ffffffff -- (.exr 0xffffffffffffffff)
ExceptionAddress: 00494653 (pico8+0x00094653)
   ExceptionCode: c0000094 (Integer divide-by-zero)
  ExceptionFlags: 00000000
NumberParameters: 0

PROCESS_NAME:  pico8.exe

ERROR_CODE: (NTSTATUS) 0xc0000094 - {

EXCEPTION_CODE: (NTSTATUS) 0xc0000094 - {

DETOURED_IMAGE: 1

MOD_LIST: <ANALYSIS/>

NTGLOBALFLAG:  0

APPLICATION_VERIFIER_FLAGS:  0

FAULTING_THREAD:  00003b44

DEFAULT_BUCKET_ID:  STATUS_INTEGER_DIVIDE_BY_ZERO

PRIMARY_PROBLEM_CLASS:  STATUS_INTEGER_DIVIDE_BY_ZERO

BUGCHECK_STR:  APPLICATION_FAULT_STATUS_INTEGER_DIVIDE_BY_ZERO

LAST_CONTROL_TRANSFER:  from 004013e2 to 00494653

STACK_TEXT:  
WARNING: Stack unwind information not available. Following frames may be wrong.
0028fec8 004013e2 00000001 00891708 00891948 pico8+0x94653
0028ff88 76ff338a 7efde000 0028ffd4 77c5a242 pico8+0x13e2
0028ff94 77c5a242 7efde000 07e2848e 00000000 kernel32!BaseThreadInitThunk+0xe
0028ffd4 77c5a215 004014c0 7efde000 00000000 ntdll!__RtlUserThreadStart+0x70
0028ffec 00000000 004014c0 7efde000 00000000 ntdll!_RtlUserThreadStart+0x1b

STACK_COMMAND:  ~0s; .ecxr ; kb

FOLLOWUP_IP: 
pico8+94653
00494653 f77c2428        idiv    eax,dword ptr [esp+28h]

SYMBOL_STACK_INDEX:  0

SYMBOL_NAME:  pico8+94653

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: pico8

IMAGE_NAME:  pico8.exe

DEBUG_FLR_IMAGE_TIMESTAMP:  21

FAILURE_BUCKET_ID:  STATUS_INTEGER_DIVIDE_BY_ZERO_c0000094_pico8.exe!Unknown

BUCKET_ID:  APPLICATION_FAULT_STATUS_INTEGER_DIVIDE_BY_ZERO_DETOURED_pico8+94653

WATSON_STAGEONE_URL:  http://watson.microsoft.com/StageOne/pico8_exe/0_0_0_0/______21/pico8_exe/0_0_0_0/______21/c0000094/00094653.htm?Retriage=1

Followup: MachineOwner

UPD: problem occurs if there is no config.txt in %APPDATA%\pico-8. Starting pico, then exiting with Alt+F4 (to create config), then starting again solves this problem.

P#29980 2016-10-04 12:55 ( Edited 2016-10-04 20:48)

Fixed for 0.1.9b, which will be up tomorrow. I've also included the updated SDL2.dll too for good measure.

When config.txt was not found, the window size was defaulting to 0,0 -- causing a divide by zero (the size < 128,128 crash bug that is also now fixed). Many thanks for the reports in this thread -- it made it much easier to track this down.

P#30078 2016-10-05 16:24 ( Edited 2016-10-05 20:24)

[Please log in to post a comment]

Follow Lexaloffle:          
Generated 2023-02-06 05:36:45 | 0.039s | Q:24