Log In  

Hey all,

I'm trying to upload a cart to itch.io. I've exported the cartridge to html, renamed the file to index.html, and zipped the html with the javascript file. When it starts on itch.io, it displays "booting cartridge" and the command prompt, but the game does not start. (If you need to see what I'm tryna describe... https://meganshaffer.itch.io/sneezr)

How do I make it so the game starts? Is there something I need to change with the html or js files?

P#49070 2018-02-07 17:39 ( Edited 2018-08-16 02:29)

You should upgrade to the latest version of PICO-8. I see you're running 0.1.11f. The latest is 0.1.11g, and that might help. Also, what happens when you run the cart locally on your own computer from the index.html page? Does your index.html version on your own computer work fine?

P#49071 2018-02-07 17:45 ( Edited 2018-02-07 22:45)

I updated, and nothing's changed. The same thing happens when I run the html file locally too :/

P#49075 2018-02-08 00:17 ( Edited 2018-02-08 05:17)

Sounds like it's probably something in the code. If you want, you can post the cart here to the forum and I (and others) can take a look at the code. If you don't want to post it, though, I'd be happy to look at it if you want to e-mail it to me. My username here is the same as my Gmail address username.

P#49079 2018-02-08 03:24 ( Edited 2018-02-08 08:24)

Oh I figured it out, it's because I didn't have an _init() function. Thanks for your offer though!

P#49100 2018-02-08 17:01 ( Edited 2018-02-08 22:01)

Great! Nice work on figuring it out. :D That's also good to know that a missing _init() will cause it to fail like that.

P#49101 2018-02-08 17:03 ( Edited 2018-02-08 22:03)

meganshaffler, I'm having the very same problem and I can't seem to be able to fix it... Could you give me some more info on how you fixed it?

I do have a _init() in my cart, so I don't really know what's going on.

P#54740 2018-08-05 14:02 ( Edited 2018-08-05 18:02)
:: dw817

Guys, I'm using itch.io for 2 of my projects.

Use the standard "EXPORT FILE.HTML" and send that straight into ITCH.IO.

According to ITCH they recommend you use the BUTLER program to upload to ITCH.

https://itch.io/docs/butler/

Hope This Helps !

P#54742 2018-08-05 16:09 ( Edited 2018-08-05 20:09)

@DevonOrxi, do you also have a game loop, ie. _update() and _draw()?

P#54923 2018-08-10 08:31 ( Edited 2018-08-10 12:31)

@dw817 I haven't tried BUTLER yet but I may, if I can't solve this issue. I exported it properly like you are saying.

@tobiasvl I do have _init(), _update() and _draw() for this project. The game works really fine in PICO! :(

P#54943 2018-08-10 21:57 ( Edited 2018-08-11 01:57)
  • if the export doesn't work locally, then it as nothing to do with itch.
  • does it work when exported as binary?
  • are you near the token/chars/compressed limits? ("info" in console)
  • are you poke()-ing around?
  • longshot, but maybe try another template? (https://www.lexaloffle.com/bbs/?tid=31000)
P#54946 2018-08-11 05:58 ( Edited 2018-08-11 09:58)
  • The export didn't work locally
  • I was really below every limit you mention
  • It worked when exported as binary, but had to set a label for it
  • Tried exporting the html again
  • Now it works and I don't know why, I didn't write/erase a single line in the original html

Nevertheless, it's working both locally and on itch.io

Thanks a lot!

P#55217 2018-08-15 22:29 ( Edited 2018-08-16 02:29)

@DevonOrxi I know this is all old but I was wondering if you can help me out on what you did and kind of explain it step by step if you can? I'm having the same issue and I know this thread talks all about it, but just reading it I still cannot figure out whats wrong.

P#62108 2019-02-20 18:51 ( Edited 2019-02-20 19:36)

[Please log in to post a comment]

Follow Lexaloffle:        
Generated 2020-04-09 22:38 | 0.040s | 2097k | Q:41