Log In  

Hiya - first post and I'm immediately asking for help. Tssk.

I'm drawing sprites to the screen, and some random colours are being displayed as black rather than the colour they are set to in the editor. However other sprites are displaying these colours correctly. Nowhere in my code do I use pal() or palt(), so although I'm assuming it's a transparency issue I don't see what I'm doing to cause it.

Thanks in advance

P#37420 2017-02-13 08:51 ( Edited 2017-02-21 15:59)

And ignore me, this was the cause...

"- The bottom half of the spritesheet and bottom half of the map occupy the same memory.
// Best use only one or the other if you're unsure how this works."

And I was trying to use both.

P#37421 2017-02-13 09:27 ( Edited 2017-02-13 14:27)

i was actually confused by this the other day and tried to find exact numbers but wasn't certain. just to make sure, does it mean that sprite 128 and forward are aliased with map values where y is at least 32?

P#37423 2017-02-13 14:05 ( Edited 2017-02-13 19:05)

Yes, I think that's exactly what's happening. You can have >127 sprites or a map.y >32 but not both.

P#37550 2017-02-17 09:00 ( Edited 2017-02-17 14:00)

Actually, you can use a piece of the given memory for each. I used the left half of that for sprites so I'd have some more and the right half for room layouts for a game.

P#37553 2017-02-17 14:01 ( Edited 2017-02-17 19:01)

@betoraposa - that's good to know! How's it done? I could see a way of setting where it got sprites from.

P#37679 2017-02-21 10:59 ( Edited 2017-02-21 15:59)

[Please log in to post a comment]

Follow Lexaloffle:          
Generated 2023-02-04 22:12:34 | 0.014s | Q:17