Log In  
Log In  

Hey everyone,

I have an issue in Pico-8. Some of the clicks are not recognized which is very frustrating because I have sometime to click multiple times to select a tile or move my cursor in the code.

I think the issue appeared only recently. I didn't update to a new pico-8 version (I use the latest v0.1.11g). The only difference I thought was that I got a Wacom tablet at christmas but after uninstalling the driver the issue is still there and I also couldn't reproduce the problem on my other machine so I doubt the problem come from here.

I wrote a short p8 program to test if it was just the pico-8 UI or also in-game and the issue also shows up in game.
You can see it in the following video (the circle are from my recording program that show system clicks)
https://www.dropbox.com/s/c1t3niaf130ljnh/Pico-8%20click%20issue%203.mp4?dl=0

The issue is clearer when I click very fast but not only. Sometimes some click events are simply not registered.

Is anyone have a similar issue?
Any idea what could cause the problem?

Pico-8: v0.1.11g
OS: macOS 10.14.2

P#60829 2019-01-14 21:45

Could you show your PICO-8 program too? Doesn't sound like you're doing anything wrong since the UI is affected, but I'd like to test anyway. I've never had this problem.

P#60843 2019-01-15 09:08
c = 1
clk = false

function clkp()
    new_clk = stat(34)==1
    result = new_clk and (clk==false)
    clk = new_clk
    return result
end

function _init()
    poke(0x5f2d, 1)
end

function _update60()
    if clkp() or btnp(5) then
        c+=1
    end

    if c>16 then
        c = 1
    end
end

function _draw()
    cls(c)
    print(stat(32),5,0,0)
    print(stat(33),5,10,0)
    print(stat(34),5,20,0)
end
P#60844 2019-01-15 09:18

Yeah, works fine for me.

P#60845 2019-01-15 10:16

Thanks for checking.

P#60846 2019-01-15 10:30

I finally found the problem.

It was caused by one program in the background that was messing up with my inputs.

The culprit is call Magnet (http://magnet.crowdcafe.com/) which let you dock windows (win10 style)

I will send them a bug report but for now on at least I know how to avoid the problem.

P#60892 2019-01-16 14:24

Nice catch! Sounds suboptimal.

P#60909 2019-01-16 21:11

[Please log in to post a comment]

X
About | Contact | Updates | Terms of Use
Follow Lexaloffle:        
Generated 2019-03-22 21:16 | 0.017s | 2097k | Q:22