Web
Analytics
Log In  

1

Hi all, I'm not sure if this is the best place to post but I'm having some difficulty with the latest 32 bit Linux pico8:

When trying to run the executable I get:

bash: ./pico8: cannot execute binary file: Exec format error

Upon looking into it further, I ran file pico8 which gave the following output:

pico8: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.32, BuildID[sha1]=a589ada4e62f733db872d5a55494f1af37f66726, not stripped

Which sounds a bit like it's a 64-bit executable despite being downloaded from the 32-bit link. This is the latest version v0.0.11f; the previous version I was using, v0.1.10c worked fine for me. Any help would be very much appreciated! Thanks!

P#47919 2018-01-06 15:43 ( Edited 2018-01-09 16:23)

::

The file command never lies. If it says itís a 64 bit executable, then itís 64 bit.

P#47998 2018-01-09 15:56

::

Sorry about that -- I've fixed this for 0.1.11g which will be available shortly.

P#48002 2018-01-09 16:23

Log in to post a comment

user:
password:

New User | Account Help
:: New User
X
About | Contact | Updates | Terms of Use
Follow Lexaloffle:        
Generated 2018-05-21 20:22 | 0.198s | 1572k | Q:13