Log In  

Hello

I use NixOS on my PCs and was able to start Pico-8 using the script https://nixos.wiki/wiki/PICO-8. Unfortunately I have no success with the script when starting Picotron. The console gives me the error "could not create renderer" and there is nothing helpful in the log.

[000000 000] Starting Picotron 0.1.0d
[000000 000] build: 240327-042435
[000011 000] creating process [root]
[000013 001] mount: [/] [/home/user/.lexaloffle/Picotron/drive]
[000048 001] Reading controller mappings: /home/user/.lexaloffle/Picotron/sdl_controllers.txt
[000048 001] searching for joysticks
[000048 001] found 0 joysticks
[000048 001] ok

Can someone tell me which packages Picotron needs to run on Linux?

Greetings TinBlock50

P#144572 2024-03-26 20:18

We're also curious - right now we're using steam-run like it's a videogame, but that feels a little hacky.

P#144584 2024-03-26 21:22

i don't have a nixos desktop env set up, so i can't say for sure, but it might be SDL that you're missing? an internet search for "could not create renderer" turns up a bunch of SDL, i'm pretty sure i've seen mention of SDL somewhere while interacting with picotron, and the script you linked didn't seem to include it

P#144683 2024-03-27 13:09

Hi Amagineer. Thank you for your input. Unfortunately adding the SDL packages did not work. I can run Picotron with Steam for the moment but it would be nice to be able to run it without steam.

P#144694 2024-03-27 14:12
3

After some trial and error and strace, I finally had success. The nix-shell script to start Picotron on NixOS is:

{ pkgs ? import <nixpkgs> {} }:
let fhs = pkgs.buildFHSUserEnv {
  name = "picotron";
  targetPkgs = pkgs: (with pkgs; [
    xorg.libXrandr # for renderer
    libGL # for renderer
    alsa-lib # for audio
    udev # for gamepads
  ]);
  runScript = "bash -c ./picotron";
};
in pkgs.stdenv.mkDerivation {
  name = "picotron-shell";
  nativeBuildInputs = [ fhs ];
  shellHook = ''
     exec picotron
    '';
}

Have fun.

P#145003 2024-03-29 16:36 ( Edited 2024-03-29 17:19)
1

Thank you so much!

Oh, update: you also want to include wget for downloading BBS carts! I remember that was what PICO-8 used, too.

P#145118 2024-03-30 14:42

[Please log in to post a comment]