Log In  

I have a cart used as an ongoing reminder alarm, simply showing the previous alarm, the current time, and the next alarm. It runs continuously for very long periods, e.g. weeks. Indeed, this instance has been running since the week 0.2.0i came out.

Today, for the first time I've ever noticed, the display was showing a pattern of corruption. I took a screenshot, but there was no corruption in the screenshot, so I tried saving a gif. I have my gif len set to a couple of minutes, so the result is quite long.

If you pay attention, the gif shows the parts of the pattern changing every second or three:

And yet when I saved a screenshot at the same time, there was no evidence of the corruption:

I assume this is because the PNG is saved from a point in the pipeline that comes before the corruption, while the GIF is saved after the corruption.

This means the cart itself isn't producing the corruption. It's happening somewhere in the frame presentation pipeline.

Not long after I saved these, I tried to save another GIF, and the actual executable crashed.

P#77564 2020-06-02 23:13 ( Edited 2020-06-02 23:26)

:: Felice

I cheated and uploaded the logfile as an image so you could see it has a bunch of nuls, otherwise they didn't show up if I pasted it:

https://lexaloffle.com/media/12874/log.txt

The last line is where it says it's saving the file that it died during.

Other than the nuls, I don't see anything damning though.

P#77566 2020-06-02 23:24 ( Edited 2020-06-02 23:31)
:: Felice

Wait, could this be part of the problem?

From log.txt above:

  Compiled against SDL version: 2.0.2
  Linked against SDL version:   2.0.9
P#77567 2020-06-02 23:37

[Please log in to post a comment]

Follow Lexaloffle:        
Generated 2021-02-27 06:41 | 0.011s | 4194k | Q:17