Log In  

Hi to all!
I've been in love with Pico8 and the whole idea of fantasy consoles for over a year now.

Today I'd like to introduce my take at fantasy console: tako80

I've been working on it for months. I just launched the site at http://tako80.net where you can read about it and find the documentation, if you happen to be interested!

In tako80 the coding is done in Javascript and its carts run on the web. I guess it might be all a bit rough at the moment (I just finished setting up the forum but I haven't tested it thoroughly, yet! :)

To promote tako80, I launched the first TakoJam. You can read about it here http://tako80.net/takojam.

The first prize is $100. I will eventually reward a second and a third prize of $50 and $20.

If you are interested, just drop me a line! Thanks :)

P#41807 2017-06-20 13:14 ( Edited 2017-07-07 14:05)

Looks neat. Your biggest challenge I think will be in building a community---good luck! I would love to see more fantasy consoles get successful and compete, that can only be a good thing. I'm new to the idea and quite happy with Pico-8 and the well established community that came with it, myself, but hopefully you'll find some adventurous game jam types to take the plunge.

P#41850 2017-06-21 16:36 ( Edited 2017-06-21 20:36)

Hi gradualgames and thanks!
I know building a community is a long and hard process, hopefully people will pick an interest in tako80 :)

P#41859 2017-06-22 02:56 ( Edited 2017-06-22 06:56)

I've tried to install it, but it doesn't work (linux mint 18):

tako80 example
/usr/lib/node_modules/tako80/tako80.js:67
    let cartJs = fs.readFileSync('cart.js').toString();
    ^^^

SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
    at exports.runInThisContext (vm.js:53:16)
    at Module._compile (module.js:373:25)
    at Object.Module._extensions..js (module.js:416:10)
    at Module.load (module.js:343:32)
    at Function.Module._load (module.js:300:12)
    at Function.Module.runMain (module.js:441:10)
    at startup (node.js:139:18)
    at node.js:968:3

I have nodejs 4.4.7 and npm is 3.10.3

(edit) I've finally installed nodejs 6 and it works now! It looks interesting.

P#42238 2017-07-07 10:05 ( Edited 2017-07-07 14:34)

[Please log in to post a comment]

Follow Lexaloffle:        
Generated 2021-09-21 04:15:47 | 0.008s | Q:14