Log In  

Right now, many of the newer Pico8 games being made won't run on the PocketCHIP (or any older version of Pico8) but unfortunately, there isn't any error feedback when you launch the games from Splore.

Instead of giving feedback, the little load spinner just stops and you're back at Splore (actually, you never leave). No response, no screen flash, no nothing. So you try again and get the same result, thus you give up and move on.

I'd think having some sort of messaging in Splore when something doesn't load would be possible and VERY helpful to users. We get a message when Splore can't connect to the BBS, there should be one when a cart fails.

The response wouldn't have to be specific at all...just something as generic as, "could not load cart" or something - anything that lets the person know something is up. Maybe that "something" might get them to ask around and see what the issue is - or raise an issue - or even update their Pico8 version.

In a perfect world, the error message would know between a bad cart due to some coding error, and a bad cart due to being incompatible with an outdated version of Pico8. Again, some message that lets people know they need to do something rather than just assuming the cart is busted.

Either way, any feedback is better than no feedback.

The more games that start to fail silently, the more credibility Pico8 loses as a good, fun platform.

We can't fix this on 0.1.7, obviously, but would like to think it's something that can be considered for future Pico8 versions, especially PocketCHIP versions.

P#32296 2016-11-07 10:06 ( Edited 2016-11-07 19:22)

What does PocketCHIP run? If it is something like Debian can it not be force updated?

--Edit

Been reading and it is Debian as the base OS with packages removed, specialty packages installed and some custom stuff. So it should, in theory, be perfectly possible to open a terminal on it and use wget to download the file and replace the current Pico 8 files on the system.

P#32297 2016-11-07 10:28 ( Edited 2016-11-07 15:39)

Directions from Next Thing recommend you flash it to get the latest versions. I'm not savvy enough to fumble around with Linux to update, so I'm inclined to follow their directions - was bummed to see a full flash was required to get updates :(

P#32299 2016-11-07 10:52 ( Edited 2016-11-07 15:52)

Seems a bit of a backwards thing. As a full flash will probably kill all your stored programs too. Unless they use some sort of partitioned space.

If you don't feel confident though I don't blame you for not wanting to try. I remember my first days in Linux, back in 2000, and I must have killed my system a half dozen times before before getting used to how the meaty and fun commands work.

P#32300 2016-11-07 11:22 ( Edited 2016-11-07 16:22)

I don't have too much installed, thankfully, so if it comes down to flashing I can without too much hassle. Just reinstalling/configuring the emulators, really. But then also means I'll use a flash drive for files rather than store things local - just an inconvenience, really.

I've used Linux on and off for 15 years and still don't have a good foundation. Every command I run outside of git is a prayer.

P#32306 2016-11-07 14:22 ( Edited 2016-11-07 19:22)

[Please log in to post a comment]

About | Contact | Updates | Terms of Use
Follow Lexaloffle:        
Generated 2019-09-23 02:42 | 0.012s | 4194k | Q:17