Log In  

In macOS (Big Sur but possibly others), there are a few bugs related to the selected system audio output device.

A) PICO-8 uses the audio output device selected by the OS at start-up time, and does not change when a different output device is selected while PICO-8 is running.

Repro:

  1. Select an audio output device, such as the laptop speakers.
  2. Open PICO-8.
  3. Test that audio is played from the laptop speakers. (E.g. draw then play a sfx.)
  4. Change the audio output device, such as headphones, using System Preferences or the Audio taskbar menu.
  5. Retry the audio test.

Expected: Audio should be emitted out of the new output device (headphones) and not the original device (laptop speakers).

Actual: Audio continues to be emitted by the original device.

B) If the output device that PICO-8 detects during start-up is no longer available, audio stops working entirely. In the SFX editor, the note playback indicator is also affected, which might hint at a cause.

Repro:

  1. In macOS, select a removable audio device, such as Bluetooth headphones.
  2. Open PICO-8, then open the SFX editor.
  3. Draw a sound and test playback with the spacebar. The sound plays and the note indicator moves.
  4. Disconnect the removable audio device, thereby changing the OS default output device.
  5. Press spacebar.

Expected: The sound plays as normal through the new audio output device.

Actual: No sound is played. The note indicator highlights the currently selected note, but does not move. Pressing the spacebar again to stop playback restores the note indicator back to the cursor. sfx(1) from the command prompt also does nothing after #3, but it does return.

Workaround for both issues: Save your work and restart PICO-8 after changing audio output devices.

PICO-8 0.2.1b, macOS Big Sur 11.0.1.

P#84777 2020-11-27 22:49


[Please log in to post a comment]

Follow Lexaloffle:        
Generated 2022-08-13 05:50:36 | 0.004s | Q:9